Reigle 技術ブログ

プログラミング、IT関連の記事中心

エラー

FlutterでFirebaseCoreのエラー firebase_core: Using Firebase SDK version '9.5.0' defined in 'firebase_core'

目次 エラー発生のタイミング エラーの内容 対応方法 エラー発生のタイミング Flutterにて、Firebaseを導入するために、「pubspec.yaml」に以下を追加した際に発生しました。 〜〜〜省略〜〜〜 dependencies: 〜〜〜省略〜〜〜 firebase_core: ^1.23.0 〜〜…

Flutterで「One or more plugins require a higher Android SDK version」のエラーが出た場合

目次 エラーの内容 対応方法 エラーの内容 「One or more plugins require a higher Android SDK version」のエラーは、簡単に言うと、「コンパイルで使用しているAndroid SDKバージョンが古いから新しくしてね。」と言うエラーです。 Flutterのバージョンを…

nginxでReactのSPAデプロイした場合、ブラウザリロードで404エラーになる場合の解決方法

目次 はじめに nginxの設定 はじめに ReactでSPAの任意のWebアプリを作成します。 ローカルホストでは、ブラウザリロードなどを行っても正常に機能しますが、nginxのサーバーにデプロイした際に404エラーが発生する場合の解決方法を記載します。 nginxの設定…

コンソールに表示されるエラー「Unchecked runtime.lastError: The message port closed before a response was received.」に関して

目次 エラーに関して エラーの原因 対応方法 エラーに関して コンソールに出力されるエラーは以下です。 Unchecked runtime.lastError: The message port closed before a response was received. 上記のエラーは画面表示時に出力されます。 ローカルサーバ…